Car Stereo is the #1 Car Audio Online Resource for radio,speakers, MP3, amps, subwoofers, box enclosures, IASCA,DB Drag Racing, USACi and MECA events Car Stereo is the #1 Car Audio Online Resource
Car Stereo is the #1 Car Audio Online Resource
Car Stereo is the #1 Car Audio Online Resource  Welcome to CarStereo.com the Internet Guide to Car Audio Car Stereo is the #1 Car Audio Online ResourceMY ACCOUNT   
Car Stereo is the #1 Car Audio Online Resource
OnlineCarStereo.com
The best and biggest selection of mobile audio/stereo, multimedia/navigation and accessories at the lowest prices! Kenwood, Pioneer, Rockford Fosgate, JVC, Sony, Clarion, Jensen, Infinity, Kicker and more...
Car Audio Black Friday Sales!
Message Forums Car Stereo Message Forums > Amplifiers > Killing my alternator
Go Back Pages (1): [1]
Author
Thread Post New Thread    Post A Reply
subaru96
New Member

 Killing my alternator

I have a 300 watt amp, it is hardwired to my battery. My alternator keeps getting fried. Is there anyway I can put a switch in to stop power from constantly going to the amp?

Report this post to a moderator

New Post 09-15-2011 09:38 PM
Click Here to See the Profile for subaru96 Click here to Send subaru96 a Private Message Find more posts by subaru96 Add subaru96 to your buddy list Edit/Delete Message Reply w/Quote
Ianarian
Member

 RE: Killing my alternator

quote:
Originally posted on 09-15-2011 by subaru96
I have a 300 watt amp, it is hardwired to my battery. My alternator keeps getting fried. Is there anyway I can put a switch in to stop power from constantly going to the amp?

LOL, I think you may want power constantly going to the amp, when in use. How many alts have you fried?

Report this post to a moderator

New Post 09-15-2011 10:56 PM
Click Here to See the Profile for Ianarian Click here to Send Ianarian a Private Message Find more posts by Ianarian Add Ianarian to your buddy list Edit/Delete Message Reply w/Quote
SINTORMAN
Senior Member

 RE: Killing my alternator

quote:
Originally posted on 09-15-2011 by subaru96
I have a 300 watt amp, it is hardwired to my battery. My alternator keeps getting fried. Is there anyway I can put a switch in to stop power from constantly going to the amp?

I think you mean battery? An alternator doesn't die from 300 watts and especially not when the car is off lol.

Report this post to a moderator

New Post 09-16-2011 12:16 AM
Click Here to See the Profile for SINTORMAN Click here to Send SINTORMAN a Private Message Find more posts by SINTORMAN Add SINTORMAN to your buddy list Edit/Delete Message Reply w/Quote
subaru96
New Member

 

Have gone through 3 alternators. The battery's are fine each time. I was thinking to put the switch in so I can shut it off when not in use.

Report this post to a moderator

New Post 09-16-2011 12:29 AM
Click Here to See the Profile for subaru96 Click here to Send subaru96 a Private Message Find more posts by subaru96 Add subaru96 to your buddy list Edit/Delete Message Reply w/Quote
SINTORMAN
Senior Member

 RE:

quote:
Originally posted on 09-16-2011 by subaru96
Have gone through 3 alternators. The battery's are fine each time. I was thinking to put the switch in so I can shut it off when not in use.

Your amp isn't the problem. Something is ruining your alternators. Have you taken one to your dealer or even autozone to see what they think? Something in your system is killing your alts. Prolly your onboard voltage regulator, poor wiring or overheating. Who has installed your alternators?

Report this post to a moderator

New Post 09-16-2011 12:50 AM
Click Here to See the Profile for SINTORMAN Click here to Send SINTORMAN a Private Message Find more posts by SINTORMAN Add SINTORMAN to your buddy list Edit/Delete Message Reply w/Quote
Ianarian
Member

 RE:

quote:
Originally posted on 09-16-2011 by subaru96
Have gone through 3 alternators. The battery's are fine each time. I was thinking to put the switch in so I can shut it off when not in use.

Should shut off with the source... When not in use, you are at idling current. Which is probably not much more than charging a cell phone. I use a switch for my master over ride system kill. You can get one at radio shack. It will wire in series on the remote of the amp. Easy to do.

Report this post to a moderator

New Post 09-16-2011 09:01 AM
Click Here to See the Profile for Ianarian Click here to Send Ianarian a Private Message Find more posts by Ianarian Add Ianarian to your buddy list Edit/Delete Message Reply w/Quote
crummorton
New Member

 

Dude you have something horribly wrong. the amp should run + straight to a fuse then to the battery,not the alternator if u did that lol. neg to frame somewhere making sure good contact no paint rust anything. and i dont believe any 300watt amp unless defective will harm a stock alternator properly installed. the remote turn on wire should be hooked radio to amp this is your turn on switch. radio turns on amp turns on simple did u wire remote turn on to constant power? kill batteries or did u hook main power from amp to the alternator? kill alternator

Report this post to a moderator

New Post 09-16-2011 10:42 PM
Click Here to See the Profile for crummorton Click here to Send crummorton a Private Message Find more posts by crummorton Add crummorton to your buddy list Edit/Delete Message Reply w/Quote
seanhennesey
New Member

 damn

damn dude who wired your system up lol they had no idea wat the were doin your power strip should have a fuse on it then it conects to your batery but ya if you want to shut you amp off when you want just get a cuttoff switch and conect it to your power strip the you just flip the switch and it will shut off or on.

Report this post to a moderator

New Post 09-26-2011 11:32 AM
Click Here to See the Profile for seanhennesey Click here to Send seanhennesey a Private Message Find more posts by seanhennesey Add seanhennesey to your buddy list Edit/Delete Message Reply w/Quote
Author
Thread Post New Thread    Post A Reply
Go Back Pages (1): [1]

Show Printable Version  |   Email this Page  |   Subscribe to this Thread


   
 Recently Logged In Members  
2rgrbn, from Long Beach, CA. RampagesZ, from Mobile, AL. kaotiksyko, from , CO. Rol886, from Rockaway Beach, NY. Dayton605, from Dayton, TX. banelsonms, from Moss Point, MS. weezer4rock, from , . jaboran, from swanton, OH. N2Audio, from Lawrence, KS. wolfantry, from erie, PA. IBBumpin, from Columbus, NE. tjsaudio, from anytown, MI. punkroc719, from Winchester, VA. Andrew, from Linden, MI. #1audio, from newport, NC. torawi01, from Corpus Christi, TX. Stripedss, from Hampton, GA. NRred2, from New York, NY. becesaudio, from davao city, AL. ipodzrcool, from , AL.
see more member photos  post your members photo

 

 

 previous page Back Email this page to a Friend 
Home  |  Contact Us  |  About Us  |  Advertise  |  Join!  |  Log-In
 
Copyright © 2006 Online ConneXions Inc.
Web Designed & Hosting