Car Stereo is the #1 Car Audio Online Resource for radio,speakers, MP3, amps, subwoofers, box enclosures, IASCA,DB Drag Racing, USACi and MECA events Car Stereo is the #1 Car Audio Online Resource
Car Stereo is the #1 Car Audio Online Resource
Car Stereo is the #1 Car Audio Online Resource  Welcome to CarStereo.com the Internet Guide to Car Audio Car Stereo is the #1 Car Audio Online ResourceMY ACCOUNT   
Car Stereo is the #1 Car Audio Online Resource
OnlineCarStereo.com
The best and biggest selection of mobile audio/stereo, multimedia/navigation and accessories at the lowest prices! Kenwood, Pioneer, Rockford Fosgate, JVC, Sony, Clarion, Jensen, Infinity, Kicker and more...
Car Audio Black Friday Sales!
Message Forums Car Stereo Message Forums > Head Units > Poor Sound from New Alpine CDE-121
Go Back Pages (1): [1]
Author
Thread Post New Thread    Post A Reply
willjr
New Member

 Poor Sound from New Alpine CDE-121

I have a 96 Toyota camry with factory, non amplified radio and factory speakers.  I wanted to add a small sub, so in order to be able to have low level outs for  a cleaner signal for my new amp and sub, I decied to install a basic head unit that would have the outputs I need for my amp.

I found an Alpine CDE-121 that I thought may be ok.  I bought it andI installed it today, and have not been very impressed with the sound of it.  My Basic factory radio drove my speakers better. The bass is now muddy sounding, with very little definition..  all around my factory unit sounded much cleaner than this stereo.  Did I just get a faulty product, or is this what's to be expected with an entry level HU.

I was hoping that alpine still made decent stuff, but maybe not at this price range. 

I expected the sound with the new Alpine would be a little better than what it was with the original hu.

Any recommendations are appreciated.

 

 

Report this post to a moderator

New Post 09-20-2011 07:16 PM
Click Here to See the Profile for willjr Click here to Send willjr a Private Message Find more posts by willjr Add willjr to your buddy list Edit/Delete Message Reply w/Quote
newfosgatesucks
Senior Member

 

A line level convertor tapped off the rear outs of your stock unit is the way to go.  Or you can fork over 250ish for a little better head unit. 

The 121 doesn't have front outs I don't think, so adding a small amp is a little harder.....

 

 So its like this - BUy a H/U with more outs and pick up a little amp, or buy a H/U with more juice....

   I'd pimp the stock unit, keeps thieves out.

Report this post to a moderator

New Post 09-23-2011 01:16 AM
Click Here to See the Profile for newfosgatesucks Click here to Send newfosgatesucks a Private Message Find more posts by newfosgatesucks Add newfosgatesucks to your buddy list Edit/Delete Message Reply w/Quote
willjr
New Member

 

The alpine has 2 rca outputs on the back  that are for subwoofer out only. Mono only I only wanted to add my sub and jl Jx-250 mono amp to give a little bass in the car.

Report this post to a moderator

New Post 09-23-2011 08:09 AM
Click Here to See the Profile for willjr Click here to Send willjr a Private Message Find more posts by willjr Add willjr to your buddy list Edit/Delete Message Reply w/Quote
newfosgatesucks
Senior Member

 

Correct, but to adress the poor sound - there are a few ways about it.   Adding an external amplifier is one, but you'll need a LOC(line output converter) to feed the amp.

THe other way would be a pricier H/U, with either : (A)higher power for speakers or(B) rca outputs for fronts, allowing external amp.

 

IT seems the natural thing here would be a line out converter on the stock unit, as it has sufficient power for the speakers it was designed to push.   The LOC would feed your sub amp.  

 

   THat is unless of course your goal is to have some added features which the stock unit does not offer. 

OF course, you could always use a line converter on the alpine to feed a front amplifier, kind of redundant though...

Report this post to a moderator

New Post 09-23-2011 01:20 PM
Click Here to See the Profile for newfosgatesucks Click here to Send newfosgatesucks a Private Message Find more posts by newfosgatesucks Add newfosgatesucks to your buddy list Edit/Delete Message Reply w/Quote
willjr
New Member

 

Took back the alpine today and picked up a Pioneer DEH-3300UB for about $99.00, it puts the alpine to shame. All 4 of my speakers are sounding much better than they did with the factory unit, and 5 times better than they sounded with the alpine. The alpine sound was pathetic. This pioneer sounds really great,, it must have a much better amplifier section. It's amazing the difference between the alpin and Pioneer. I had read on this forum that the pioneers were good units for the money, and it definately is.

Report this post to a moderator

New Post 09-23-2011 05:47 PM
Click Here to See the Profile for willjr Click here to Send willjr a Private Message Find more posts by willjr Add willjr to your buddy list Edit/Delete Message Reply w/Quote
Author
Thread Post New Thread    Post A Reply
Go Back Pages (1): [1]

Show Printable Version  |   Email this Page  |   Subscribe to this Thread


   
 Recently Logged In Members  
RampagesZ, from Mobile, AL. Rol886, from Rockaway Beach, NY. Dayton605, from Dayton, TX. reagan1, from Rowlett, TX. soltany, from beirut, MI. 2rgrbn, from Long Beach, CA. kaotiksyko, from , CO. banelsonms, from Moss Point, MS. weezer4rock, from , . jaboran, from swanton, OH. N2Audio, from Lawrence, KS. wolfantry, from erie, PA. IBBumpin, from Columbus, NE. tjsaudio, from anytown, MI. punkroc719, from Winchester, VA. Andrew, from Linden, MI. #1audio, from newport, NC. torawi01, from Corpus Christi, TX. Stripedss, from Hampton, GA. NRred2, from New York, NY.
see more member photos  post your members photo

 

 

 previous page Back Email this page to a Friend 
Home  |  Contact Us  |  About Us  |  Advertise  |  Join!  |  Log-In
 
Copyright © 2006 Online ConneXions Inc.
Web Designed & Hosting