Car Stereo is the #1 Car Audio Online Resource for radio,speakers, MP3, amps, subwoofers, box enclosures, IASCA,DB Drag Racing, USACi and MECA events Car Stereo is the #1 Car Audio Online Resource
Car Stereo is the #1 Car Audio Online Resource
Car Stereo is the #1 Car Audio Online Resource  Welcome to CarStereo.com the Internet Guide to Car Audio Car Stereo is the #1 Car Audio Online ResourceMY ACCOUNT   
Car Stereo is the #1 Car Audio Online Resource
OnlineCarStereo.com
The best and biggest selection of mobile audio/stereo, multimedia/navigation and accessories at the lowest prices! Kenwood, Pioneer, Rockford Fosgate, JVC, Sony, Clarion, Jensen, Infinity, Kicker and more...
Car Audio Black Friday Sales!
Message Forums Car Stereo Message Forums > Subwoofers and Speakers > Subwoofer Troubleshooting
Go Back Pages (1): [1]
Author
Thread Post New Thread    Post A Reply
gurlyclimber
New Member

 Subwoofer Troubleshooting

I have a Pioneer Deh 3500 deck with a 12" Kicker sub and a 600 watt Sony Xplode amp.  The deck is connecteed to the amp with a 12' RCA cable.  My speakers are not blown but they sound like it when reaching high volumes.  This happens whether or not the sub is connected.  When the sub is connected, you can see movement, however there is barely any bass.  Could the problem be that my RCA cables are too long, when I can clearly use a 6' cable?  What else can the problem be?  Thank you.

Report this post to a moderator

New Post 02-21-2012 11:53 PM
Click Here to See the Profile for gurlyclimber Click here to Send gurlyclimber a Private Message Find more posts by gurlyclimber Add gurlyclimber to your buddy list Edit/Delete Message Reply w/Quote
Author
Thread Post New Thread    Post A Reply
Go Back Pages (1): [1]

Show Printable Version  |   Email this Page  |   Subscribe to this Thread


   
 Recently Logged In Members  
kaotiksyko, from , CO. RampagesZ, from Mobile, AL. Rol886, from Rockaway Beach, NY. Dayton605, from Dayton, TX. banelsonms, from Moss Point, MS. weezer4rock, from , . jaboran, from swanton, OH. N2Audio, from Lawrence, KS. wolfantry, from erie, PA. 2rgrbn, from Long Beach, CA. IBBumpin, from Columbus, NE. tjsaudio, from anytown, MI. punkroc719, from Winchester, VA. Andrew, from Linden, MI. #1audio, from newport, NC. torawi01, from Corpus Christi, TX. Stripedss, from Hampton, GA. NRred2, from New York, NY. becesaudio, from davao city, AL. ipodzrcool, from , AL.
see more member photos  post your members photo

 

 

 previous page Back Email this page to a Friend 
Home  |  Contact Us  |  About Us  |  Advertise  |  Join!  |  Log-In
 
Copyright © 2006 Online ConneXions Inc.
Web Designed & Hosting