Car Stereo is the #1 Car Audio Online Resource for radio,speakers, MP3, amps, subwoofers, box enclosures, IASCA,DB Drag Racing, USACi and MECA events Car Stereo is the #1 Car Audio Online Resource
Car Stereo is the #1 Car Audio Online Resource
Car Stereo is the #1 Car Audio Online Resource  Welcome to CarStereo.com the Internet Guide to Car Audio Car Stereo is the #1 Car Audio Online ResourceMY ACCOUNT   
Car Stereo is the #1 Car Audio Online Resource
OnlineCarStereo.com
The best and biggest selection of mobile audio/stereo, multimedia/navigation and accessories at the lowest prices! Kenwood, Pioneer, Rockford Fosgate, JVC, Sony, Clarion, Jensen, Infinity, Kicker and more...
Car Audio Black Friday Sales!
Message Forums Car Stereo Message Forums > Amplifiers > Need help with my amp installation
Go Back Pages (1): [1]
Author
Thread Post New Thread    Post A Reply
jaxonhargrove
New Member

 Need help with my amp installation

I purchased a Boss r2002 2-channel, 400-watt amp to power my 10inch Pioneer sub. When i first got it, i installed the same way every book, video, and forum said i should. I used the Boss 8-gauge installation kit. The I have the power connected to the battery, the ground on an unpainted area of the frame, and a 50 amp inline fuse on the battery connection. The first amp worked perfect for about a week, then the power started to cut in and out. By week 2, the amp was completely dead. So i returned it. I got the new one, installed it using the same connections and fuses, and it worked fine, for about a week. Now the amp is suddenly completely dead and will not power on at all. Is this a manufacture's error, or a user error. Please help! Thanks! Jaxon Hargrove

Report this post to a moderator

New Post 08-13-2012 01:34 PM
Click Here to See the Profile for jaxonhargrove Click here to Send jaxonhargrove a Private Message Find more posts by jaxonhargrove Add jaxonhargrove to your buddy list Edit/Delete Message Reply w/Quote
roseywat
New Member

 Reply

I think you should consult the technical expert who can guide you better. http://www.mcintoshlabs.com/us/Products/pages/categorylanding.aspx?CatId=Amplifiers

Report this post to a moderator

New Post 09-07-2012 06:42 AM
Click Here to See the Profile for roseywat Click here to Send roseywat a Private Message Find more posts by roseywat Add roseywat to your buddy list Edit/Delete Message Reply w/Quote
Author
Thread Post New Thread    Post A Reply
Go Back Pages (1): [1]

Show Printable Version  |   Email this Page  |   Subscribe to this Thread


   
 Recently Logged In Members  
tjsaudio, from anytown, MI. RampagesZ, from Mobile, AL. 2rgrbn, from Long Beach, CA. IBBumpin, from Columbus, NE. gmc2002ss, from Baton Rouge, LA. Raglandc, from Grand Rapids, MI. Altbs, from Ligonier, IN. jaboran, from swanton, OH. punkroc719, from Winchester, VA. Dayton605, from Dayton, TX. Rol886, from Rockaway Beach, NY. reagan1, from Rowlett, TX. soltany, from beirut, MI. kaotiksyko, from , CO. banelsonms, from Moss Point, MS. weezer4rock, from , . N2Audio, from Lawrence, KS. wolfantry, from erie, PA. Andrew, from Linden, MI. #1audio, from newport, NC.
see more member photos  post your members photo

 

 

 previous page Back Email this page to a Friend 
Home  |  Contact Us  |  About Us  |  Advertise  |  Join!  |  Log-In
 
Copyright © 2006 Online ConneXions Inc.
Web Designed & Hosting